Electronic Signature
Incident Report for Admincontrol
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 17:15 CEST
Monitoring
A fix have been implemented and we are seeing an improvement on the affected service.

We are continuing to monitor the situation.
Posted Apr 23, 2024 - 16:48 CEST
Identified
Our provider has identified the root cause of the electronic signature issue and is currently working on implementing mitigating actions.

While the problem persists, users may continue to experience difficulties signing documents
Posted Apr 23, 2024 - 16:25 CEST
Investigating
We are currently experiencing problems with electronic signature in our application. This is affecting the possibility to sign documents. Creating and managing signature requests are working as normal.

We are working with our signature provider to identify the root cause of the issue.

We apologize for any inconvenience this may cause.

We'll provide further updates as soon as more information becomes available. Thank you for your understanding.
Posted Apr 23, 2024 - 15:53 CEST
This incident affected: Board Portal (Electronic Signing).