Website - admincontrol.com

Incident Report for Admincontrol

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 18:40 CEST

Identified

The issue is located at a third party provider. They are working on fixing the issue.

We apologise for the inconvenience that this is causing. https://admincontrol.com/ is still working as normal.
Posted Oct 02, 2025 - 16:02 CEST

Investigating

We are currently experiencing a service disturbance with our web page. The disturbance is affecting the Danish, Finnish and the Swedish landing pages. Investigations to resolve the issue are ongoing.

https://admincontrol.com/ is working as normal
Posted Oct 02, 2025 - 14:10 CEST
This incident affected: Website (admincontrol.com).