Email service disturbances

Incident Report for Admincontrol

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 20:05 CEST

Monitoring

We are closely monitoring our providers efforts to resolve the issue. We are seeing a higher success rate and smaller delays than earlier.
Posted Sep 30, 2025 - 15:22 CEST

Identified

Our third party are continuing working on a fix. Currently emails are processed with delay.
Posted Sep 30, 2025 - 13:38 CEST

Investigating

We are currently experiencing issues with sending email from the service.

There is identified an issue with a third party provider causing emails not being sent. We will provide an update as soon as we have new information.

We apologise for the inconvenience this issue may cause you.
Posted Sep 30, 2025 - 13:16 CEST
This incident affected: Services (E-mail providers), Board Portal (Notifications), and Data Room (Notifications).